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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For example,
“copy file1” means you must type the word copy, then type a space, and then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For example,
“click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to press the
key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in italics.
For example, “copy filename” means you must type the word copy, then type a space,
and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the keys
at the same time. For example, “Press Shift+F1” means to press the Shift key and, while
holding it down, press the F1 key also. You should always depress the modifier key or keys
first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and then press
the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and contains
multiple tabs. Each tab has relevant commands that are organized, grouped, and labeled.
An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab. An
image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an application
arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the Filemenu
and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-mouse
button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands from
the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This Getting Started Guide leads you step-by-step through creating, solving, and analyzing the
results of a parameterized 2D model.

This guide explains how to perform the following tasks in 2D Extractor:

l Drawing a geometric model
l Modifying a model’s design parameters
l Assigning conductors
l Running Reduce Matrix operations
l Specifying solution settings for a design
l Validating a design’s setup
l Running a 2D Extractor simulation
l Plotting results

The Model
The model consists of a central rectangle and three thin rectangular copper conductors on top,
and one long conductor on the bottom.

A copy of this model is located in the \AnsysEM installation folder under \
[Release#]\Examples\2D Extractor.

In the following sections, you will recreate this model, analyze it, perform a reduce matrix
operation, run a frequency sweep, run a parametric sweep, and plot the results.

Getting Started with Q3D Extractor: A 2D Grounded Coplanar Waveguide Model
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2 - Creating the Model
This section explains how to perform the following tasks:

l Launching 2D Extractor and saving a new project
l Setting the units of measure for the design
l Drawing the model
l Assigning conductors

Launching 2D Extractor and Saving a New Project
A project is a collection of one or more designs that is saved in a single file. A new project is
automatically created when 2D Extractor is launched. Open 2D Extractor and save the default
project under a new name.

1. Launch Ansys Electronics Desktop.
2. Click New to create a new, empty project.

The project appears in the Project Manager, with the default name Project#. The number
depends on the number of projects already in existence.

Project definitions, such as material assignments, are stored in the Definitions folder under
the project name.

3. Click Project > Insert 2D Extractor Design.
An empty 2D Extractor design appears in the Project Manager:

4. Click File > Save As.
The Save As window appears.

Getting Started with Q3D Extractor: A 2D Grounded Coplanar Waveguide Model
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5. Locate a folder in which you want to save the project.
6. In the File Name field, type cpw_gnd_gsg.aedt.
7. Click Save.

The file cpw_gnd_gsg.aedt is saved to the folder you selected.

Setting the Model Units of Measure
Set the units of measurement for drawing the geometric model.

1. ClickModeler > Units.

The Set Model Units dialog box appears.

Creating the Model 2-2
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2. If it is not already selected, use the Select units drop-down menu to selectmm.
3. ClickOK.

Drawing the Model

Drawing the Substrate
Perform the following steps:

1. Click Draw > Rectangle.

TheMeasure Data dialog box appears, displaying the coordinates of the cursor in the
Modeling area.

Creating the Model 2-3
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The current cursor position is displayed next to Position2(Current).

2. Click to draw the lower-left corner of the rectangle at position (-0.5, 0, 0).
3. Click to draw the upper-right corner of the rectangle at position (0.5, 0.2, 0).

The rectangle is created. It appears in the Modeling area, and as Rectangle1 in the History
Tree.

Creating the Model 2-4
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Important:

After its creation, the rectangle and the CreateRectangle action are selected in the
History Tree by default.

If you have deselected them, ensure they are selected for the next steps.

4. From the Properties window, select the Attribute tab:

5. Click in the Name | Value field and rename Rectangle1 to Substrate.
6. Press Enter to confirm the new name.
7. Select the Command tab.

Creating the Model 2-5
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8. In the Ysize | Value field, type diel_thick and press Enter.

The Add Variable dialog box appears.

9. From the Unit Type drop-down menu, select Length.
10. From the Unit drop-down menu, select mm.
11. In the Value field, enter 0.2.
12. ClickOK.

YSize is now defined as the local variable diel_thick.

Creating the Model 2-6
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13. From the Properties window, select the Attribute tab again.
14. Select theMaterial | Value field and use the drop-down menu to select Edit.

The Select Definition window appears.

15. Click Add Material.

The View/Edit Material window appears.

16. In theMaterial Name field, type silicon_lossy.
17. Click Set Frequency Dependency.

The Frequency Dependent Material Setup Option dialog box appears.

Creating the Model 2-7
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Djordjevic-Sarkar is the recommended frequency dependent material model as it ensures
causality for subsequent time-domain simulations.

18. Select Djordjevic-Sarkar Model Input and clickOK.

The Djordjevic-Sarkar Model Input window appears.

Creating the Model 2-8
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19. In the Relative Permittivity field, type 11.
20. In the Loss Tangent field, type 0.02.
21. Leave other fields as-is, and clickOK.
22. ClickOK three more times to return to the Modeling window.

Drawing the Ground
Now you will draw another rectangle at the base of Substrate.

1. Click Draw > Rectangle.

TheMeasure Data dialog box appears, displaying the coordinates of the cursor in the
Modeling area.

2. Click to draw the upper-left corner of the rectangle at position (-0.5,0,0).
3. Click to draw the lower-right corner of the rectangle at position (0.5,-0.01,0).

Note:

You may need to zoom in on the Modeling area, either using the zoom options on
the View tab or using your mouse's scroll wheel.

The rectangle is created as Rectangle1.

Creating the Model 2-9
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Important:

After its creation, the rectangle and the CreateRectangle action are selected in the
History Tree by default.

If you have deselected them, ensure they are selected for the next steps.

4. From the Properties window, select the Attribute tab.
5. Click in the Name | Value field and rename Rectangle1 toGround.
6. Press Enter to confirm the new name.

Creating the Top Grounds
You will draw two more rectangles for ground planes:

1. Click Draw > Rectangle. Draw a rectangle of any size, anywhere in the Modeling
workspace.

Important:

After its creation, the rectangle and the CreateRectangle action are selected in the
History Tree by default.

If you have deselected them, ensure they are selected for the next steps.

2. On the Attribute tab, click in the Name | Value field and rename Rectangle1 to top_gnd1.

Creating the Model 2-10
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3. Resize and reposition the rectangle using the Command tab in the Properties window.

4. For the Position | Value, enter -0.5, diel_thick, 0.

The Y point is parameterized so that top_gnd1 stays connected to Substrate as its
thickness changes. You can see that diel_thick is translated to 0.2mm in the Evaluated
Value field.

5. For the XSize | Value, enter 0.374.
6. For the YSize | Value, enter 0.01.

To create the second ground, you will duplicate this one.

1. Select top_gnd1 and click Edit > Duplicate > Mirror.

TheMeasure Data dialog box appears.

2. Click the origin, then at any point along the X-axis to duplicate.

Creating the Model 2-11
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top_gnd1 is duplicated as top_gnd1_1.

3. Select top_gnd1_1.
4. In the Properties window, select the Attributes tab.
5. Rename top_gnd1_1 to top_gnd2.

Creating the Trace
You will draw one final rectangle to represent a trace.

1. Click Draw > Rectangle. Place the rectangle anywhere in the Modeling workspace.

Rectangle1 is created.

Creating the Model 2-12
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Important:

After its creation, the rectangle and the CreateRectangle action are selected in the
History Tree by default.

If you have deselected them, ensure they are selected for the next steps.

2. On the Attribute tab, click in the Name | Value field and rename Rectangle1 to trace.
3. Resize and reposition the rectangle using the Command tab in the Properties window.
4. For the Position | Value, enter -0.05, diel_thick, 0.

The Y point is parameterized so the trace stays connected to Substrate as its thickness
changes. You can see that diel_thick is translated to 0.2mm in the Evaluated Value field.

5. For the XSize | Value, enter 0.1.
6. For the YSize | Value, enter 0.01.

The project should look like this (colors have been changed for visibility):

Assigning Conductors
Next, you will assign conductors.

1. Select trace and click 2D Extractor > Conductor > Assign > Signal Line.

The Signal Line dialog box appears.

Creating the Model 2-13
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2. Leave the default values and clickOK to return to the Modeling workspace.
3. SelectGround and click 2D Extractor > Conductor > Assign > Reference Ground.

The Reference Ground dialog box appears.

Creating the Model 2-14
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4. Leave the default values and clickOK to return to the Modeling workspace.
5. Ctrl + click to select top_gnd1 and top_gnd2, then click 2D Extractor > Conductor >

Assign > Non Ideal Ground.

The Non Ideal Ground window appears.

Creating the Model 2-15
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6. At the bottom of the window, select Create Single Conductor. Leave all other options as
their default values.

7. ClickOK.

This joins the two coplanar grounds in parallel, and concludes conductor assignment.

Creating the Model 2-16
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3 - Setting Up an Analysis
This section explains how to perform the following tasks:

l Adding a solution setup
l Adding a frequency sweep
l Performing a Reduce Matrix operation
l Validating the setup

Adding a Solution Setup
To add the solution setup:

1. Click 2D Extractor > Analysis Setup > Add Solution Setup.

The Solve Setup window appears, on theGeneral tab.

Getting Started with Q3D Extractor: A 2D Grounded Coplanar Waveguide Model
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2. Adjust the settings, as follows:
l On theGeneral tab:
1. Verify that the Solution Frequency is set to 3 GHz.
2. Ensure the Admittance (Capacitance/Conductance) check box is selected.
3. Ensure the Impedance (Resistance/Inductance) check box is selected.
4. In bothMaximum Number of Passes fields, enter 20.

l On the CG Advanced tab:
1. In theMinimum Converged Passes field, enter 2.
2. Ensure the Use Loss Convergence check box is selected.

l On the RL Advanced tab:

Setting Up an Analysis 3-2
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1. In the Minimum Converged Passes field, enter 2.
2. Ensure the Use Loss Convergence check box is selected.

3. Leave all other settings as their defaults, and clickOK.

The setup is listed as Setup1 in the Project Manager under Analysis.

Adding a Frequency Sweep
Next, add a frequency sweep:

1. Click 2D Extractor > Analysis Setup > Add Frequency Sweep.

The Select dialog box appears.

2. Select Setup1 and clickOK.

Setting Up an Analysis 3-3
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The Edit Frequency Sweep window appears.

3. Use the Delete Selection button to remove all but one row.
4. Edit the remaining row. Use the Distribution drop-down menu to select Linear Step.
5. Adjust the settings as follows:

l In the Start box, enter 0.1 GHz.
l In the Stop box, enter 3 GHz.
l In the Step Size box, enter 0.1 GHz.

6. ClickOK.

The frequency sweep is listed as Sweep1 in the Project Manager under Setup1

Setting Up an Analysis 3-4
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.

Performing a Reduce Matrix Operation
Perform a Reduce Matrix operation:

1. Click 2D Extractor > Reduce Matrix > Add Ground.

The Reduce Operation window appears.

Setting Up an Analysis 3-5

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Q3D Extractor: A 2D Grounded Coplanar Waveguide Model

2. In the Select from Conductors List table, select top_gnd1.

This ties the objects top_gnd1, top_gnd2 and Ground in parallel and treats them as the
reference ground.

3. Click Save and Close.

Validating the Setup
Before solving, you must verify that all the steps have been properly completed.

1. Click 2D Extractor > Validation Check.

The Validation Check window appears.

When the check has finished, the window reads "Validation Check completed."

Setting Up an Analysis 3-6

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Q3D Extractor: A 2D Grounded Coplanar Waveguide Model

2. Verify that there is a green check mark next to each item.

Important:

If there are any errors, the window will display a red X next to the item in the list
containing an error. Should that occur, go back and verify that you performed the
previous steps correctly.

3. Click Close.

Setting Up an Analysis 3-7

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



PDF layout 3-8

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Getting Started with Q3D Extractor: A 2D Grounded Coplanar Waveguide Model



4 - Running the Analysis
This section explains how to perform the following tasks:

l Solving for Admittance and Impedance
l Generating Reporter plots
l Generating Field plots
l Exporting a Circuit model
l Adding a Parametric sweep
l Running a Parametric analysis

Solving for Admittance and Impedance
If you have no errors from the validation check, you are ready to launch the solvers.

To run the analysis that you set up earlier:

1. In the Project Manager, right-click Setup1 and select Analyze.

The Progress window displays a progress bar.

2. To view details about the simulation in progress, right-click Setup1 and select
Convergence.

The Solutions window appears, on the Convergence tab.

Getting Started with Q3D Extractor: A 2D Grounded Coplanar Waveguide Model
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The table shows how the mesh grows from one adaptive solution pass to the next and how
much the solution changes (delta%) between passes.

3. Use the CG drop-down menu to select RL.

Convergence information for the impedance solution displays.

Running the Analysis 4-2
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4. Select theMatrix tab.
5. Use theOriginal drop-down menu to select AddGroundMatrix.

Running the Analysis 4-3
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6. If desired, use the other tabs to view additional information:
l Profile – run-time profile information, such as the amount of CPU time or memory used in

the solution.
l Tline Data – characteristic impedance and cross-talk coefficients.
l Mode Data – propagation data, such as velocity and attenuation.
l Mesh Statistics – mesh element information.

7. Click Close.

Generating Reporter Plots

R Matrix Plots
After running the simulation, you can view various plots.

First, view the resistance vs. frequency plot:

Running the Analysis 4-4
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1. Click 2D Extractor > Results > Create Matrix Report > Rectangular Plot.

The Report window appears.

2. Use the Solution drop-down menu to ensure Setup1:Sweep1 is selected.
3. Use theMatrix drop-down menu to select AddGroundMatrix.
4. In the Category list, select R Matrix.
5. In theQuantity list, select R(trace,trace).
6. Leave the default values for all other fields, and click New Report.

The report appears as a plot in the Modeling workspace, and is listed under Results in the
Project Manager.
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7. Click Close to close the Report window.

Change the plot to a logarithmic scale:

1. Double-click the X axis.

The Properties window appears.

2. Select the X Scaling tab.
3. Use the Axis Scaling | Value drop-down menu to select Log.
4. Click Apply to update the report.
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5. ClickOK to exit the Properties window and view the updated report.

Conductance vs. Frequency Plot
Now you will generate a plot of conductance vs. frequency.

1. Click 2D Extractor > Results > Create Matrix Report > Rectangular Plot.
2. Use the Solution drop-down menu to ensure that Setup1:Sweep1 is selected.
3. Use theMatrix drop-down menu to select AddGroundMatrix.
4. In the Category list, selectG Matrix.
5. In theQuantity list, selectG(trace,trace).
6. Leave the default values for all other fields, and click New Report.
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7. Click Close to close the Report window and view the report.

Generating Field Plots

VectorE Field Plot
Field plots represent basic or derived quantities on surfaces of objects.

You will plot Vector E for CG:

1. Return to the Modeling workspace by double-clicking 2DExtractorDesign1 in the Project
Manager.

2. Select the Substrate object.
3. Click 2D Extractor > Fields > CG Fields > E > VectorE.

The Create Field Plot window appears.
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4. Use the In Volume list to select Substrate.
5. Leave the default values, and click Done.

The plot appears in the Modeling workspace.
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You can double-click the legend to make modifications.

For example, to modify the arrow size: select theMarker/Arrow tab and then drag the Size
slider under Arrow Options.

JrL Field Plot
Now you will plot current density for the RL solution.

1. In the Modeling workspace, select all of the following objects:
l Ground
l top_gnd1
l top_gnd2
l Trace

2. Click 2D Extractor > Fields > RL Fields > J > JrL.

The Create Field Plot window appears.

Running the Analysis 4-10

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Q3D Extractor: A 2D Grounded Coplanar Waveguide Model

3. Leave all default values unchanged, and click Done.

The field plot appears, atop the previous plot.
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You can see that a large amount of current is returning through the coplanar grounds.

You can change the amount of current (RL) or voltage (CG) that is applied to a particular
conductor, by clicking 2D Extractor > Fields > Edit Sources.

Changing Overlay Visibility
The VectorE and JrL field plots appear in the Project Manager under Field Overlays.
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Right-click either and deselect Plot Visibility to hide the field plot. Re-select Plot Visibility to
show the plot.

Exporting a Circuit Model
Now that you have the solution, you will export a SPICE model to simulate the effects of the trace
on a signal that passes through it.

1. In the Project Manager, right-click Setup1 and select Export Circuit.

The Export Circuit window appears.
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2. Use the Solution drop-down menu to select Setup1:Sweep1.
3. Specify a circuit type for export:

a. Click the ellipses button (...) next to File Name.
b. Use the drop-down menu to select Nexxim/HSPICE W Element (*.sp).
c. Specify a File Name and select a location to save the file.
d. ClickOpen to return to the Export Circuit window.

Since we chose to export based on the sweep solution, a tabular W element table model
(RLGC data at each frequency point) will be created.
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4. Click Export Circuit.

A dialog box opens, alerting you that the file has been created.

5. ClickOK to exit the dialog box.
6. Click Close to exit the Export Circuit window.

Currently, the model has only a single variable available for the nominal value diel_thick
(0.2mm).

Next you will set up a parametric analysis to sweep the variable over a range of values. This will
allow you to export different equivalent circuit models corresponding to the different values of
these variables.

Adding a Parametric Sweep
A parametric setup is made up of one or more variable sweep definitions. A variable sweep
definition is a set of variable values within a range that Optimetrics drives 2D Extractor to solve
when the parametric setup is analyzed. You can add one or more sweep definitions to a
parametric setup.

1. Click 2D Extractor > Optimetrics Analysis > Add Parametric.

The Setup Sweep Analysis window appears, on the Sweep Definitions tab.

2. Click Add.

The Add/Edit Sweep window appears.

3. Use the Variable drop-down menu to ensure that diel_thick is selected.
4. Use the radio buttons to ensure that Linear Step is selected.
5. Enter the following values:

l Start: 0.2mm
l Stop: 0.5mm
l Step: 0.05mm

6. Click Add.
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The sweep is added to the list on the right.

7. ClickOK to add the sweep.
8. ClickOK to close the Setup Sweep Analysis window.

The model is simulated with various values in the specified range, including the start and
stop values.

The sweep is listed in the project tree underOptimetrics as ParametricSetup1.

Now you will add an output calculation of the resistance matrix.

1. In the Project Manager, right-click ParametricSetup1 and select Properties.

The Setup Sweep Analysis window opens again.
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2. Select the Calculations tab.
3. Click Setup Calculations.

The Add/Edit Calculations window appears.

4. Use the Report Type drop-down menu to verify thatMatrix is selected.
5. Use the Solution drop-down menu to select Setup1:LastAdaptive.
6. Use theMatrix drop-down menu to select AddGroundMatrix.
7. In the Category list, select R Matrix.
8. In the Quantity list, select R(trace,trace).
9. Click Add Calculation.
10. Click Done to exit the Add/Edit Calculation window.
11. ClickOK to exit the Setup Sweep Analysis window.

Running a Parametric Analysis
For this project, you want to see only the nominal (3GHz) resistance at each parametric
variation. Therefore, you can disable the frequency sweep before beginning the parametric
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solution. This will significantly decrease the parametric solution time.

From the Project Manager, right-click Sweep1, and select Disable Sweep.

Now you can run the parametric analysis.

1. From the Project Manager, right-click ParametricSetup1 and select Analyze.
The Progress window displays a progress bar.

2. From the Project Manager, right-click ParametricSetup1 and select View Analysis
Result.
The Post Analysis Display window appears.

The parametric result shows how the resistance gets larger as the ground plane moves
farther away from the trace. When the ground plane is farther away, more current returns in
the nearby coplanar grounds (top_gnd1 and top_gnd2), which have a smaller effective
cross-section.

Click Table to view a list of the diel_thick values that have been solved.
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3. Click the Profile tab to view how long it took to solve each variation.
4. Click Close to exit the Post Analysis Display window.
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